BackBox Requirements Linux 4.4 System

Backbox requirements

What is BackBox Requirements?

It is Linux distro based on Ubuntu.  It is widely used for Penetration Testing and Security auditing. It has lots of Penetration tools. The backbox requirements for Latest release of BackBox

system requirements backbox Linux 4.4

Do you think about Live CD or USB?

It is true, you can run  live OS by DVD/USB drive. If you want to install on Virtualbox or Hard drive. Before start installation you should be aware about requirements for run and install BackBox.

Here is BackBox system Requirements:

  • 32-bit or 64-bit processor
  • 512 MB of system memory (RAM)
  • 6 GB of disk space for installation
  • Graphics card capable of 800×600 resolution
  • DVD-ROM drive or USB port (2 GB)

 

BackBox Linux 4.4 released

BackBox Linux 4.4 realsed

Ubunut 14.04 based Penetration Testing Distribution BackBox Linux 4.4 released

Officially BackBox Linux 4.4 released, announced by its team, This release have included some new special features to make it up to date of security world. this is a great released for hackers and pententester
Do you want download it ?
Yes, I know your feelings and I am going to provide locations where you can download latest ISO images

http://www.backbox.org/downloads

BackBox Linux 4.4 released

What is new in this release?
Let’s know

  • according blog post by  team the new added features are following
  • Preinstalled Linux Kernel 3.19
  • New Ubuntu 14.04.3 base
  • Ruby 2.1
  • Installer with LVM and Full Disk Encryption options
  • Handy Thunar custom actions
  • RAM wipe at shutdown/reboot
  • System improvements
  • Upstream components
  • Bug corrections
  • Performance boost
  • Improved Anonymous mode
  • Automotive Analysis category
  • Predisposition to ARM architecture (armhf Debian packages)
  • Predisposition to Cloud platform
  • New and updated hacking tools: apktool, armitage, beef-project, can-utils, dex2jar, fimap, jd-gui, metasploit-framework, openvas, setoolkit, sqlmap, tor, weevely, wpscan, zaproxy, etc.

Requirement for this Linux 4.4 Operating System

Check out system requirement here